#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\+(?<code>\d))?(?<number>\d+)$"
Local $sString = "+718341233124" & @CRLF & _
"+118341233124" & @CRLF & _
"518341233124" & @CRLF & _
"" & @CRLF & _
"d718341233124" & @CRLF & _
"+71834123adg3124" & @CRLF & _
"7-18341233124" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")