const regex = /^(?:\+(?<code>\d))?(?<number>\d+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\+(?<code>\\d))?(?<number>\\d+)$', 'gm')
const str = `+718341233124
+118341233124
518341233124
d718341233124
+71834123adg3124
7-18341233124
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}