import re
regex = re.compile(r"^(?:\+(?<code>\d))?(?<number>\d+)$", flags=re.MULTILINE)
test_str = ("+718341233124\n"
"+118341233124\n"
"518341233124\n\n"
"d718341233124\n"
"+71834123adg3124\n"
"7-18341233124\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")