#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https://(?!ru)[.\w]*?site.com(?!/ru)[/.\w]*?/aid/"
Local $sString = "<l>https://uz.site.com/en/aid/</l>" & @CRLF & _
"<l>https://site.com/ru/aid/</l>" & @CRLF & _
"<l>https://site.com/eu/aid/</l>" & @CRLF & _
"<l>https://site.com/aid/</l>" & @CRLF & _
"<l>https://ru.site.com/uk/aid/</l>" & @CRLF & _
"<l>https://fr.site.com/fr/aid/</l>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")