re = /https:\/\/(?!ru)[.\w]*?site.com(?!\/ru)[\/.\w]*?\/aid\//m
str = '<l>https://uz.site.com/en/aid/</l>
<l>https://site.com/ru/aid/</l>
<l>https://site.com/eu/aid/</l>
<l>https://site.com/aid/</l>
<l>https://ru.site.com/uk/aid/</l>
<l>https://fr.site.com/fr/aid/</l>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end