import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https://(?!ru)[.\\w]*?site.com(?!/ru)[/.\\w]*?/aid/";
final String string = "<l>https://uz.site.com/en/aid/</l>\n"
+ "<l>https://site.com/ru/aid/</l>\n"
+ "<l>https://site.com/eu/aid/</l>\n"
+ "<l>https://site.com/aid/</l>\n"
+ "<l>https://ru.site.com/uk/aid/</l>\n"
+ "<l>https://fr.site.com/fr/aid/</l>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}