using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https://(?!ru)[.\w]*?site.com(?!/ru)[/.\w]*?/aid/";
string input = @"<l>https://uz.site.com/en/aid/</l>
<l>https://site.com/ru/aid/</l>
<l>https://site.com/eu/aid/</l>
<l>https://site.com/aid/</l>
<l>https://ru.site.com/uk/aid/</l>
<l>https://fr.site.com/fr/aid/</l>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}