const regex = new RegExp('https://(?!ru)[.\\w]*?site.com(?!/ru)[/.\\w]*?/aid/', 'gm')
const str = `<l>https://uz.site.com/en/aid/</l>
<l>https://site.com/ru/aid/</l>
<l>https://site.com/eu/aid/</l>
<l>https://site.com/aid/</l>
<l>https://ru.site.com/uk/aid/</l>
<l>https://fr.site.com/fr/aid/</l>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}