$re = '/https://(?!ru)[.\w]*?site.com(?!/ru)[/.\w]*?/aid//m';
$str = '<l>https://uz.site.com/en/aid/</l>
<l>https://site.com/ru/aid/</l>
<l>https://site.com/eu/aid/</l>
<l>https://site.com/aid/</l>
<l>https://ru.site.com/uk/aid/</l>
<l>https://fr.site.com/fr/aid/</l>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);