using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"I(?:'| a)?m ([^\s]*)";
string input = @"I'm hungry
It's hot outside and I'm hungry
I'm stupid and hungry
I'm with stupid
Im hungry";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}