const regex = new RegExp('I(?:\\'| a)?m ([^\\s]*)', 'gmi')
const str = `I'm hungry
It's hot outside and I'm hungry
I'm stupid and hungry
I'm with stupid
Im hungry`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}