$re = '/I(?:\'| a)?m ([^\s]*)/mi';
$str = 'I\'m hungry
It\'s hot outside and I\'m hungry
I\'m stupid and hungry
I\'m with stupid
Im hungry';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);