import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "I(?:'| a)?m ([^\\s]*)";
final String string = "I'm hungry\n"
+ "It's hot outside and I'm hungry\n"
+ "I'm stupid and hungry\n"
+ "I'm with stupid\n"
+ "Im hungry";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}