package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)I(?:'| a)?m ([^\s]*)`)
var str = `I'm hungry
It's hot outside and I'm hungry
I'm stupid and hungry
I'm with stupid
Im hungry`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}