re = /I(?:'| a)?m ([^\s]*)/mi
str = 'I\'m hungry
It\'s hot outside and I\'m hungry
I\'m stupid and hungry
I\'m with stupid
Im hungry'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end