#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d{2,3},)+(\d{2,3}),?$|^\d{2,3}$"
Local $sString = "//pass" & @CRLF & _
"12,123,56,567,789,11" & @CRLF & _
"12,123,56,567,789,11," & @CRLF & _
"12" & @CRLF & _
"123" & @CRLF & _
"" & @CRLF & _
"//fail" & @CRLF & _
"12,123,56,567,789,11a" & @CRLF & _
"a12,123,56,567,789,11" & @CRLF & _
"12,123,56,567,789,1" & @CRLF & _
"1,123,56,567,789,11" & @CRLF & _
"1234,123,56,567,789,11" & @CRLF & _
"12,123,56,567,789,1123" & @CRLF & _
"1" & @CRLF & _
"1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")