import Foundation
let pattern = #"^(?:\d{2,3},)+(\d{2,3}),?$|^\d{2,3}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
//pass
12,123,56,567,789,11
12,123,56,567,789,11,
12
123
//fail
12,123,56,567,789,11a
a12,123,56,567,789,11
12,123,56,567,789,1
1,123,56,567,789,11
1234,123,56,567,789,11
12,123,56,567,789,1123
1
1234
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)