$re = '/^(?:\d{2,3},)+(\d{2,3}),?$|^\d{2,3}$/m';
$str = '//pass
12,123,56,567,789,11
12,123,56,567,789,11,
12
123
//fail
12,123,56,567,789,11a
a12,123,56,567,789,11
12,123,56,567,789,1
1,123,56,567,789,11
1234,123,56,567,789,11
12,123,56,567,789,1123
1
1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);