import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d{2,3},)+(\\d{2,3}),?$|^\\d{2,3}$";
final String string = "//pass\n"
+ "12,123,56,567,789,11\n"
+ "12,123,56,567,789,11,\n"
+ "12\n"
+ "123\n\n"
+ "//fail\n"
+ "12,123,56,567,789,11a\n"
+ "a12,123,56,567,789,11\n"
+ "12,123,56,567,789,1\n"
+ "1,123,56,567,789,11\n"
+ "1234,123,56,567,789,11\n"
+ "12,123,56,567,789,1123\n"
+ "1\n"
+ "1234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}