// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d{2,3},)+(\d{2,3}),?$|^\d{2,3}$").unwrap();
let string = "//pass
12,123,56,567,789,11
12,123,56,567,789,11,
12
123
//fail
12,123,56,567,789,11a
a12,123,56,567,789,11
12,123,56,567,789,1
1,123,56,567,789,11
1234,123,56,567,789,11
12,123,56,567,789,1123
1
1234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}