package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{[^}]+\}|[^,.\s\[\]]+`)
var str = `RR,target_value,006EI4ZXZALFXAT2E4AHX2O6V,006EI4ZXZALFXAT2E4AHX2O6V,dynamic,{\"(MEASURES_DIMENSION)\":\"006EI4ZXZALFXAT2E4AHX2O6V\",\"ZR_ITEM__ZR_BRAND\":\"0000000201\"},cell_selection,34932,#FFFFFF,,25,[{\"color\":\"#566C6C\",\"from\":\"10\",\"to\":\"50\",\"icon\":\"fa://minus-with-square\",\"size\":\"30\",\"angle\":\"45\"}]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}