// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\{[^}]+\}|[^,.\s\[\]]+").unwrap();
let string = "RR,target_value,006EI4ZXZALFXAT2E4AHX2O6V,006EI4ZXZALFXAT2E4AHX2O6V,dynamic,{\\\"(MEASURES_DIMENSION)\\\":\\\"006EI4ZXZALFXAT2E4AHX2O6V\\\",\\\"ZR_ITEM__ZR_BRAND\\\":\\\"0000000201\\\"},cell_selection,34932,#FFFFFF,,25,[{\\\"color\\\":\\\"#566C6C\\\",\\\"from\\\":\\\"10\\\",\\\"to\\\":\\\"50\\\",\\\"icon\\\":\\\"fa://minus-with-square\\\",\\\"size\\\":\\\"30\\\",\\\"angle\\\":\\\"45\\\"}]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}