use strict;
my $str = 'RR,target_value,006EI4ZXZALFXAT2E4AHX2O6V,006EI4ZXZALFXAT2E4AHX2O6V,dynamic,{\\"(MEASURES_DIMENSION)\\":\\"006EI4ZXZALFXAT2E4AHX2O6V\\",\\"ZR_ITEM__ZR_BRAND\\":\\"0000000201\\"},cell_selection,34932,#FFFFFF,,25,[{\\"color\\":\\"#566C6C\\",\\"from\\":\\"10\\",\\"to\\":\\"50\\",\\"icon\\":\\"fa://minus-with-square\\",\\"size\\":\\"30\\",\\"angle\\":\\"45\\"}]';
my $regex = qr/\{[^}]+\}|[^,.\s\[\]]+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}