import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{[^\\}]+\\}|[^,.\\s\\[\\]]+";
final String string = "RR,target_value,006EI4ZXZALFXAT2E4AHX2O6V,006EI4ZXZALFXAT2E4AHX2O6V,dynamic,{\\\"(MEASURES_DIMENSION)\\\":\\\"006EI4ZXZALFXAT2E4AHX2O6V\\\",\\\"ZR_ITEM__ZR_BRAND\\\":\\\"0000000201\\\"},cell_selection,34932,#FFFFFF,,25,[{\\\"color\\\":\\\"#566C6C\\\",\\\"from\\\":\\\"10\\\",\\\"to\\\":\\\"50\\\",\\\"icon\\\":\\\"fa://minus-with-square\\\",\\\"size\\\":\\\"30\\\",\\\"angle\\\":\\\"45\\\"}]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}