# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\{[^}]+\}|[^,.\s\[\]]+"
test_str = "RR,target_value,006EI4ZXZALFXAT2E4AHX2O6V,006EI4ZXZALFXAT2E4AHX2O6V,dynamic,{\\\"(MEASURES_DIMENSION)\\\":\\\"006EI4ZXZALFXAT2E4AHX2O6V\\\",\\\"ZR_ITEM__ZR_BRAND\\\":\\\"0000000201\\\"},cell_selection,34932,#FFFFFF,,25,[{\\\"color\\\":\\\"#566C6C\\\",\\\"from\\\":\\\"10\\\",\\\"to\\\":\\\"50\\\",\\\"icon\\\":\\\"fa://minus-with-square\\\",\\\"size\\\":\\\"30\\\",\\\"angle\\\":\\\"45\\\"}]"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.