const regex = /\{[^}]+\}|[^,.\s\[\]]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{[^}]+\\}|[^,.\\s\\[\\]]+', 'g')
const str = `RR,target_value,006EI4ZXZALFXAT2E4AHX2O6V,006EI4ZXZALFXAT2E4AHX2O6V,dynamic,{\\"(MEASURES_DIMENSION)\\":\\"006EI4ZXZALFXAT2E4AHX2O6V\\",\\"ZR_ITEM__ZR_BRAND\\":\\"0000000201\\"},cell_selection,34932,#FFFFFF,,25,[{\\"color\\":\\"#566C6C\\",\\"from\\":\\"10\\",\\"to\\":\\"50\\",\\"icon\\":\\"fa://minus-with-square\\",\\"size\\":\\"30\\",\\"angle\\":\\"45\\"}]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}