# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b1?_lasso(?![^\W_])/Lasso/gm;t' <<< "1_lasso
_lasso
1_lasso_olsps
_lasso_olsps"