use strict;
my $str = '1_lasso
_lasso
1_lasso_olsps
_lasso_olsps';
my $regex = qr/\b1?_lasso(?![^\W_])/mp;
my $subst = 'Lasso';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";