$re = '/\b1?_lasso(?![^\W_])/m';
$str = '1_lasso
_lasso
1_lasso_olsps
_lasso_olsps';
$subst = "Lasso";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;