#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b1?_lasso(?![^\W_])"
Local $sString = "1_lasso" & @CRLF & _
"_lasso" & @CRLF & _
"1_lasso_olsps" & @CRLF & _
"_lasso_olsps"
Local $sSubst = "Lasso"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)