import Foundation
let pattern = #"\b1?_lasso(?![^\W_])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1_lasso
_lasso
1_lasso_olsps
_lasso_olsps
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Lasso"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)