using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b1?_lasso(?![^\W_])";
string substitution = @"Lasso";
string input = @"1_lasso
_lasso
1_lasso_olsps
_lasso_olsps";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}