# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^produtos\/([^\/]*)(?:\/(.*))?/categorias.php?id_categoria=$1&id_subcategoria=$2/g;t' <<< "produtos/nome-categoria/sub-categoria"