package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^produtos/([^/]*)(?:/(.*))?`)
var str = `produtos/nome-categoria/sub-categoria`
var substitution = "categorias.php?id_categoria=$1&id_subcategoria=$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}