use strict;
my $str = 'produtos/nome-categoria/sub-categoria';
my $regex = qr;^produtos/([^/]*)(?:/(.*))?;p;
my $subst = 'categorias.php?id_categoria=$1&id_subcategoria=$2';
my $result = $str =~ s;$regex;$subst;rg;
print "The result of the substitution is' $result\n";