import Foundation
let pattern = #"^produtos/([^/]*)(?:/(.*))?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"produtos/nome-categoria/sub-categoria"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"categorias.php?id_categoria=$1&id_subcategoria=$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)