// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^produtos/([^/]*)(?:/(.*))?").unwrap();
let string = "produtos/nome-categoria/sub-categoria";
let substitution = "categorias.php?id_categoria=$1&id_subcategoria=$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}