#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^produtos/([^/]*)(?:/(.*))?"
Local $sString = "produtos/nome-categoria/sub-categoria"
Local $sSubst = "categorias.php?id_categoria=$1&id_subcategoria=$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)