# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/public\s+(.+):([^,]+),?/@prop\n\t\tpublic $1:$2;\n/gmu;t' <<< "
public typeface:Typeface,
public weight:FontWeight,
public color:Color,
public size:Units,
public line:Units,
public character:Units,
public fontStyle:ABoolean,
public decorationUnderline:ABoolean,
public decorationCrossed:ABoolean,
"