using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"public\s+(.+):([^,]+),?";
string substitution = @"@prop\n\t\tpublic $1:$2;\n";
string input = @"
public typeface:Typeface,
public weight:FontWeight,
public color:Color,
public size:Units,
public line:Units,
public character:Units,
public fontStyle:ABoolean,
public decorationUnderline:ABoolean,
public decorationCrossed:ABoolean,
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}