import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "public\\s+(.+):([^,]+),?";
final String string = "\n"
+ " public typeface:Typeface,\n"
+ " public weight:FontWeight,\n"
+ " public color:Color,\n"
+ " public size:Units,\n"
+ " public line:Units,\n"
+ " public character:Units,\n"
+ " public fontStyle:ABoolean,\n"
+ " public decorationUnderline:ABoolean,\n"
+ " public decorationCrossed:ABoolean,\n"
+ " ";
final String subst = "@prop\\n\\t\\tpublic $1:$2;\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}