package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)public\s+(.+):([^,]+),?`)
var str = `
public typeface:Typeface,
public weight:FontWeight,
public color:Color,
public size:Units,
public line:Units,
public character:Units,
public fontStyle:ABoolean,
public decorationUnderline:ABoolean,
public decorationCrossed:ABoolean,
`
var substitution = "@prop\n\t\tpublic $1:$2;\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}