# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"public\s+(.+):([^,]+),?"
test_str = ("\n"
" public typeface:Typeface,\n"
" public weight:FontWeight,\n"
" public color:Color,\n"
" public size:Units,\n"
" public line:Units,\n"
" public character:Units,\n"
" public fontStyle:ABoolean,\n"
" public decorationUnderline:ABoolean,\n"
" public decorationCrossed:ABoolean,\n"
" ")
subst = "@prop\\n\\t\\tpublic $1:$2;\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.UNICODE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.