#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\([^)]+\d{4}\)|(?<=^|\s)(?:.(?!\([^)]+\d{4}\)))+"
Local $sString = "Text text text (Hung et al., 2020; Sung et al., 2021)" & @CRLF & _
"(Hung et al., 2020; Sung et al., 2021) text text" & @CRLF & _
"Text text text (Hung et al., 2020; Sung et al., 2021) text text" & @CRLF & _
"" & @CRLF & _
" Text text text (Hung et al., 2020; Sung et al., 2021)" & @CRLF & _
"(Hung et al., 2020; Sung et al., 2021) text text " & @CRLF & _
" Text text text (Hung et al., 2020; Sung et al., 2021) text text "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)