# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\([^)]+\d{4}\)|(?<=^|\s)(?:.(?!\([^)]+\d{4}\)))+"
test_str = ("Text text text (Hung et al., 2020; Sung et al., 2021)\n"
"(Hung et al., 2020; Sung et al., 2021) text text\n"
"Text text text (Hung et al., 2020; Sung et al., 2021) text text\n\n"
" Text text text (Hung et al., 2020; Sung et al., 2021)\n"
"(Hung et al., 2020; Sung et al., 2021) text text \n"
" Text text text (Hung et al., 2020; Sung et al., 2021) text text ")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.