use strict;
my $str = 'Text text text (Hung et al., 2020; Sung et al., 2021)
(Hung et al., 2020; Sung et al., 2021) text text
Text text text (Hung et al., 2020; Sung et al., 2021) text text
Text text text (Hung et al., 2020; Sung et al., 2021)
(Hung et al., 2020; Sung et al., 2021) text text
Text text text (Hung et al., 2020; Sung et al., 2021) text text ';
my $regex = qr/\([^)]+\d{4}\)|(?<=^|\s)(?:.(?!\([^)]+\d{4}\)))+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";