re = /\([^)]+\d{4}\)|(?<=^|\s)(?:.(?!\([^)]+\d{4}\)))+/m
str = 'Text text text (Hung et al., 2020; Sung et al., 2021)
(Hung et al., 2020; Sung et al., 2021) text text
Text text text (Hung et al., 2020; Sung et al., 2021) text text
Text text text (Hung et al., 2020; Sung et al., 2021)
(Hung et al., 2020; Sung et al., 2021) text text
Text text text (Hung et al., 2020; Sung et al., 2021) text text '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result