using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\([^)]+\d{4}\)|(?<=^|\s)(?:.(?!\([^)]+\d{4}\)))+";
string substitution = @"";
string input = @"Text text text (Hung et al., 2020; Sung et al., 2021)
(Hung et al., 2020; Sung et al., 2021) text text
Text text text (Hung et al., 2020; Sung et al., 2021) text text
Text text text (Hung et al., 2020; Sung et al., 2021)
(Hung et al., 2020; Sung et al., 2021) text text
Text text text (Hung et al., 2020; Sung et al., 2021) text text ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}