import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\([^)]+\\d{4}\\)|(?<=^|\\s)(?:.(?!\\([^)]+\\d{4}\\)))+";
final String string = "Text text text (Hung et al., 2020; Sung et al., 2021)\n"
+ "(Hung et al., 2020; Sung et al., 2021) text text\n"
+ "Text text text (Hung et al., 2020; Sung et al., 2021) text text\n\n"
+ " Text text text (Hung et al., 2020; Sung et al., 2021)\n"
+ "(Hung et al., 2020; Sung et al., 2021) text text \n"
+ " Text text text (Hung et al., 2020; Sung et al., 2021) text text ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}