#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^| )hoi($| )|(^| )hallo($| )|(^| )ok($| )|(^| )doei($| )"
Local $sString = "ik zag hem en toen zei hij hallo" & @CRLF & _
"hoi hoe is het" & @CRLF & _
"het is ok blijkbaar" & @CRLF & _
"doei" & @CRLF & _
"twee hallos werkt niet" & @CRLF & _
"hhhhoi stotterde hij" & @CRLF & _
"doeiii"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")